eNSP 安装指北【附视频】

image-20210104172416686

视频版

  

视频播放不清晰,可以跳转到 B 站观看:https://www.bilibili.com/video/BV1FK4y1T7MT

 

文字版

Step 1:安装准备

1.1 软件下载

1.1.1 主程序

来源:默认网盘

1.1.2 依赖程序

来源:默认网盘
来源:默认网盘
来源:默认网盘

1.2 安装环境检查

1.2.1 检查之前是否已经安装过 eNSP 和依赖软件,如果有先请卸载,包括依赖软件一起卸载。

1.2.2 如果之前安装过 eNSP ,请使用注册表清理工具清理一下注册表【此步骤谨慎操作,注册表比较重要,请在有备份的情况下清理,清理出错可能会导致系统不可用】。

1.2.3 eNSP 安装和使用过程中请将 Windows 防火墙关闭。

1.3 系统配置要求

image-20210106162426456

Step 2:软件安装

2.1 安装依赖程序

请按照文档安装顺序进行,变更安装顺序可能会导致安装出错!

2.1.1 安装 WinPcap

1、下载完成后,双击安装包,单击【Next】

image-20210104175415844

2、单击【I Agree】

image-20210104175532735

3、保持默认,单击【Install】

image-20210104175620300

4、单击【Finish】完成安装

image-20210104175718318

2.1.2 安装 Wireshark

1、下载完成后,双击安装包,单击【Next】

image-20210104180413236

2、单击【I Agree】

image-20210104180435674

3、保持默认,单击【Next】

image-20210104180538719

4、保持默认,单击【Next】

image-20210104180621137

5、保持默认(可以修改安装路径,但不建议),单击【Next】

image-20210104180650713

6、保持默认,单击【Next】

image-20210104180732109

7、保持默认,单击【Install】

image-20210104180903949

8、等待安装完成

image-20210104181039427

9、在弹出的新窗口中单击【I Agree】,开始下一步安装

image-20210104181205363

10、保持默认,点击【Install】

image-20210104181357210

11、单击【Next】

image-20210104181546015

12、单击【Finish】,完成 Npcap 安装,等待 Wireshark 安装完成

image-20210104181817847

13、单击【Next】

image-20210104181958032

14、保持默认,单击【Finish】完成安装

image-20210104182230189

2.1.3 安装 VirtualBox

1、下载完成后,双击安装包,单击【下一步】

image-20210104182550408

2、保持默认,点击【下一步】

image-20210104182608972

3、保持默认,点击【下一步】

image-20210104182653650

4、点击【是】确认安装

image-20210104182713139

5、点击【安装】开始安装

image-20210104183053334

6、在弹出的窗口中点击【安装】

image-20210104182920836

7、去掉勾选,点击【完成】完成安装

image-20210104183007902

至此,依赖程序安装完成!

2.2 安装主程序

1、下载完成后,双击安装包,选择安装语言【中文(简体)】,单击【确定】

image-20210104192551308

2、单击【下一步】

image-20210104192634134

3、勾选【我愿意接受此协议】,单击【下一步】

image-20210104192810548

4、保持默认(可以修改安装路径),单击【下一步】

image-20210104192909119

5、保持默认,单击【下一步】

image-20210104193022648

6、保持默认,单击【下一步】

image-20210104193052663

7、依赖环境已提前安装,直接单击【下一步】

image-20210104193139256

8、单击【安装】,开始安装

image-20210104193215520

9、等待安装完成

image-20210104193244792

10、去掉所有勾选,单击【完成】完成安装

image-20210104193515824

Step 3:测试 eNSP

3.1 打开 eNSP

1、双击桌面“eNSP”图标,打开 eNSP 软件

image-20210104195521818

2、如果出现“Windows 安全中心警报”,单击【允许访问】,并确认 Windows 防火墙是否已经关闭,如果未关闭,请关闭 Windows 防火墙

image-20210104195631351

3、eNSP 初始界面

image-20210104195925638

4、认识 eNSP 主界面

image-20210106115231330

  • 工具栏:提供常用的工具,如新建拓扑、打印等。
  • 工作区:提供设备和网线,供选择到工作区。
  • 网络设备区:在此区域创建网络拓扑。

3.2 通过单臂路由实验测试 eNSP 是否可以正常使用

3.2.1 新建拓扑,并开启设备

1、从网络设备区中拖出一台路由器,一台交换机,两台 PC 机到工作区,并用网线连接起来,组成一张拓扑图

image-20210106113329510

2、框选所有图标,单击工具栏的绿色开机按钮开启设备

image-20210106113814486

3、等待设备启动

image-20210106113849185

4、开启完成

image-20210106115642188

3.2.2 配置设备

1、配置路由器和交换机,将以下配置命令分别复制粘贴到路由器和交换机中

AR1

system-view
sysname AR1

interface GigabitEthernet0/0/0.1
 dot1q termination vid 10
 ip address 192.168.10.254 255.255.255.0 
 arp broadcast enable

interface GigabitEthernet0/0/0.2
 dot1q termination vid 20
 ip address 192.168.20.254 255.255.255.0 
 arp broadcast enable
 quit
quit

LSW1

system-view
sysname LSW1
vlan batch 10 20

interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 10
 
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 20
 
interface GigabitEthernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 10 20
 quit
quit

2、配置 PC1 和 PC 2,双击 PC 机图标,按下图将 IP 地址、子网掩码、网关填写好,并单击【应用】保存

PC 1

image-20210106160152405

PC 2

image-20210106160250433

3、测试网络连通性,选择 PC 2 点击到“命令行”,输入“ping 192.168.10.1”,按【回车】,输出如下图内容,即为配置完成

image-20210106160549847

Step 4:总结

4.1 总结

至此,eNSP 就安装完成了,并且通过实验测试 eNSP 可以正常使用。

|| 版权声明
作者:Guangran
链接:https://www.rsecc.cn/archives/395.html
声明:如无特别声明本文即为原创文章仅代表个人观点,版权归《广然笔记》所有,欢迎转载,转载请保留原文链接。
THE END
分享
二维码
< <上一篇
下一篇>>
文章目录
关闭
目 录